Denning Landseer - Only Starts from Sub starter

New Users (or anyone else) is/are welcome to ask questions in here to which the answers might be obvious to most but you simply don't know yourself or are unsure where to find the answer. You can also ask questions about the working of the forum or anything else you may think of.

Moderator: MAN 16.242

Forum rules
### This section is a NO FLAMING ZONE! That means you cannot reply "harshly", abusively, sarcastically or in any negative manner to members. ###
Post Reply
User avatar
TroyP-4216
Posts: 0
Joined: Mon Apr 02, 2018 3:06 am
Favourite Vehicle: Denning Landseer

Denning Landseer - Only Starts from Sub starter

Post by TroyP-4216 »

Hello all.

I am co-owner of an 87 Landseer that will not start from the key switch. When you turn the key, the dash lights up etc but when you turn to start, nothing happens.
We are lucky enough to have some Denning manuals and they refer to a " start safety switch" between the key switch and the start relay. Would anyone happen to know where this is located?
We're hoping it may just be a problem with the start relay though.

thanks in advance

Troy
User avatar
boronia
Posts: 19542
Joined: Fri Mar 05, 2004 7:18 pm
Favourite Vehicle: Fire engine; PD4107
Location: Sydney

Re: Denning Landseer - Only Starts from Sub starter

Post by boronia »

The safety switch is usually on the engine hatch, to prevent the engine being started while someone is working on it. If the door is not closed properly, you can't start it.
The Sydney Classic and Antique Truck (and Bus) Show
On again June 2021
@ The Museum of Fire.
User avatar
Toolman
Posts: 9
Joined: Mon Jun 04, 2012 1:58 am
Favourite Vehicle: Denning
Location: WA

Re: Denning Landseer - Only Starts from Sub starter

Post by Toolman »

There is also a switch on the swinging radiator, catch bolt end. :)
User avatar
boronia
Posts: 19542
Joined: Fri Mar 05, 2004 7:18 pm
Favourite Vehicle: Fire engine; PD4107
Location: Sydney

Re: Denning Landseer - Only Starts from Sub starter

Post by boronia »

I find it extremely rude that people come on here, ask for advice, but never follow up with feedback on suggestions made.
The Sydney Classic and Antique Truck (and Bus) Show
On again June 2021
@ The Museum of Fire.
User avatar
TroyP-4216
Posts: 0
Joined: Mon Apr 02, 2018 3:06 am
Favourite Vehicle: Denning Landseer

Re: Denning Landseer - Only Starts from Sub starter

Post by TroyP-4216 »

Thank you for the advice given. The subsequent comment about me being "rude" was not appreciated.
I will certainly provide feedback once I have had a chance to actually investigate. The coach is located interstate from me so I can't just pop out the into the backyard to look at it.
The only switches I have been find initially (at the time of making the original post) were the engine bay light switches on the side hatches.
User avatar
TroyP-4216
Posts: 0
Joined: Mon Apr 02, 2018 3:06 am
Favourite Vehicle: Denning Landseer

Re: Denning Landseer - Only Starts from Sub starter

Post by TroyP-4216 »

Spent the day investigating a few things.
No sign of any switches on the rear hatch nor on the swing out radiator unfortunately, only on the side hatches.
Found all the fuses etc and all were ok.
Still not sure where the start relay is unless it's called something different.
Have found all the relays in the front fuse panel but none labelled as a start relay.
Will continue investigating but it is very frustrating as everything seems to be working correctly other than it will not start from the ignition key.
User avatar
boronia
Posts: 19542
Joined: Fri Mar 05, 2004 7:18 pm
Favourite Vehicle: Fire engine; PD4107
Location: Sydney

Re: Denning Landseer - Only Starts from Sub starter

Post by boronia »

Power may go from the key switch direct to the starter solenoid, without needing an intermediate relay.
The Sydney Classic and Antique Truck (and Bus) Show
On again June 2021
@ The Museum of Fire.
User avatar
TroyP-4216
Posts: 0
Joined: Mon Apr 02, 2018 3:06 am
Favourite Vehicle: Denning Landseer

Re: Denning Landseer - Only Starts from Sub starter

Post by TroyP-4216 »

After changing out the start solenoid/relay (referred to as an Auxiliary Magnetic Switch) I then had a fiddle around with some connectors that I found on the oil pressure switch/sender unit.
The fault was a "dodgy" connection to chassis at this sender unit.
ozbuses
Posts: 107
Joined: Thu Aug 19, 2004 1:40 am

Re: Denning Landseer - Only Starts from Sub starter

Post by ozbuses »

Well done. Lots of people will learn from this
User avatar
boronia
Posts: 19542
Joined: Fri Mar 05, 2004 7:18 pm
Favourite Vehicle: Fire engine; PD4107
Location: Sydney

Re: Denning Landseer - Only Starts from Sub starter

Post by boronia »

I recall now that the DDEC system on Detroit diesels had a few such sensors on the engine. A bad connection or loose earth could shut the engine down.
The Sydney Classic and Antique Truck (and Bus) Show
On again June 2021
@ The Museum of Fire.
Maladjusted
Posts: 890
Joined: Sun Mar 07, 2004 11:17 am
Location: Brisbane

Re: Denning Landseer - Only Starts from Sub starter

Post by Maladjusted »

And do lots of other pain in the A things when you want to get going.
Who bleedin thanked me? I was just doin my job
bjg154
Posts: 88
Joined: Wed Feb 21, 2007 12:09 pm

Re: Denning Landseer - Only Starts from Sub starter

Post by bjg154 »

Any chance of a photo of your machine Troy?
User avatar
TroyP-4216
Posts: 0
Joined: Mon Apr 02, 2018 3:06 am
Favourite Vehicle: Denning Landseer

Re: Denning Landseer - Only Starts from Sub starter

Post by TroyP-4216 »

Not sure how to upload images sorry.
I think you have to post a link to a separate website possibly.
User avatar
Fleet Lists
Administrator
Posts: 21573
Joined: Sat Mar 06, 2004 1:49 am
Location: The Shire

Re: Denning Landseer - Only Starts from Sub starter

Post by Fleet Lists »

Living in the Shire.
User avatar
TroyP-4216
Posts: 0
Joined: Mon Apr 02, 2018 3:06 am
Favourite Vehicle: Denning Landseer

Re: Denning Landseer - Only Starts from Sub starter

Post by TroyP-4216 »

Our work in progress.
DL1201
Attachments
P1000253a.jpg
P1000253a.jpg (79.54 KiB) Viewed 9375 times
Post Reply

Return to “New Users/Ask a Simple Question”