• Advertisement

Merc 305, no gears and no starting

Discussions regarding bus to motorhome conversions are welcome here.

Merc 305, no gears and no starting

Postby Wildcatracing » Wed Jun 03, 2015 11:05 am

Hi all, we got stranded last weekend in our 305 bus (Renk 3 stage auto). I noticed that the auto would not immediately go back into top gear after shifting up from 2nd. (It has never done that before). Anyway, when we got to our destination I couldnt get it to go in reverse (it felt like a detent problem with the shifter but thats electronic). I put it in neutral and shut the engine down. Then I couldnt start it at all. Managed to start it by shorting the starter solenoid but no gears, kept playing a it went into drive so I tried to get home. Got partway home and the engine died due to air in the fuel. Fixed that and started it by shorting the starter but no gears. Managed to disconnect the stepper motor from the trans selector and manually moved it to drive and got home. I have pulled the stepper motor assembly out and it looks perfect inside but I noticed quite a lot of crap in some of the connectors in the loom to the motor. Could crappy connections cause this issue? has anyone had a similar issue? Is the starter inhibit switch part of the shifter assembly? Any help would be appreciated. Thanks Graham
Wildcatracing
 
Posts: 5
Joined: Tue Jul 27, 2010 10:22 am
Has thanked: 0 time
Been thanked: 2 times

Re: Merc 305, no gears and no starting

Postby Wildcatracing » Fri Jun 05, 2015 5:11 am

i can now answer my own questions, YES the stepper motor can cause these issues, I stripped it down and the motor itself is shagged. Hopefully I can get new brushes fitted to it
Wildcatracing
 
Posts: 5
Joined: Tue Jul 27, 2010 10:22 am
Has thanked: 0 time
Been thanked: 2 times

Re: Merc 305, no gears and no starting

Postby Boff » Sat Jun 06, 2015 11:06 am

Appreciate you taking the time to come back and conclude the discussion with an answer Graham, Hope you get it sorted.
Boff
 
Posts: 24
Joined: Thu May 26, 2011 1:27 pm
Location: Gippsland, Victoria.
Has thanked: 20 times
Been thanked: 5 times
Favourite Vehicle: MCI MC7 and early Denning's

Re: Merc 305, no gears and no starting

Postby Simes » Sat Jun 27, 2015 1:19 pm

it's a Merc O305, with a Renk transmission :shock: :?:
http://19302413.blogspot.com/

3092, last bus on George Street - 23rd October 2015 7:50pm
User avatar
Simes
 
Posts: 9061
Joined: Fri Mar 05, 2004 11:09 pm
Location: Grove of Kings
Has thanked: 131 times
Been thanked: 80 times
Favourite Vehicle: Mercedes Benz

Re: Merc 305, no gears and no starting

Postby Wildcatracing » Mon Jun 29, 2015 5:17 am

yes it is, the electric shifter unit has a stuffed contact in it and cant be repaired.
Wildcatracing
 
Posts: 5
Joined: Tue Jul 27, 2010 10:22 am
Has thanked: 0 time
Been thanked: 2 times

Re: Merc 305, no gears and no starting

Postby rustbucket » Mon Jun 29, 2015 7:52 am

I converted an AEC ex sydney bus about 40 years ago that had one of those air assisted gearshift changers.
An electricity linesman gave me a hand (didn't know JS about electrickery in those days) and he opened up this huge box full of relays and other bits and pieces that the gearshift wires ran to (from there to gearbox).
After looking at it for days scratching his head he came to the conclusion that none of it was necessary so simply bypassed the whole lot and wire the little shift lever to the gearbox.
Did a lot of miles in that bus, gears were never a problem.
Moral of the story, think beyond the box.

Rustbucket
User avatar
rustbucket
 
Posts: 35
Joined: Tue May 13, 2014 4:34 pm
Has thanked: 0 time
Been thanked: 11 times

Re: Merc 305, no gears and no starting

Postby Wildcatracing » Mon Jun 29, 2015 9:37 am

guess what, thats what I did ! I had an old shifter out of a race car so installed that with a 12 metre cable and job done. Not sure if its legal as theres no reverse switch on it as I am using the original stick to drive that. Also ran a wire direct to the starter so theres no inhibit switches to fail. It would be nice to have the original fixed but at least we are mobile again. Cheers
Wildcatracing
 
Posts: 5
Joined: Tue Jul 27, 2010 10:22 am
Has thanked: 0 time
Been thanked: 2 times



  • Advertisement

Return to Bus to motorhome discussions

Who is online

Users browsing this forum: No registered users and 1 guest